Fenêtre ArchEditor

ArchEditor est une application qui se compose d’une fenêtre de démarrage et d’une fenêtre principale.

Ecran d’accueil

Au démarrage de l’application, le premier écran propose deux options principales : créer un nouveau fichier Arch ou ouvrir un fichier existant.

Une liste affiche les fichiers Arch ouverts récemment et qui peuvent donc être ouverts directement.

On peut ouvrir un fichier directement en faisant un double-clic sur son nom.

Ecran d’accueil
Figure 1. Ecran d’accueil

Au démarrage de l’application, plusieurs options sont disponibles :

Nouveau fichier

En sélectionnant le bouton btn:[New…​], un nouvel écran apparaît comme affiché plus bas. Sur cet écran, il faut indiquer un nom et la description du nouveau fichier à créer. Alors, il est nécessaire de choisir un dictionnaire de concepts qui sera utilisé pour la saisie à venir.

Le bas de l’écran affiche des informations sur les saisies en cours. Il fournit également information sur le statut du dictionnaire choisi, voir Informations sur le statut du dictionnaire pour plus de détails.

Pour démarrer, il faut cliquer le bouton btn:[Proceed].

Ecran nouveau fichier
Figure 2. Fenêtre nouveau fichier de données de l’écran d’accueil

Fusion de fichiers

En sélectionnant btn:[Fusion…​], un nouveau panel apparaît comme visible ci-dessous.

Cet écran permet de fusionner plusieurs fichiers .arch qui partagent le même dictionnaire. Le résultat de la fusion est ensuite ouvert en edition après avoir cliqué sur le bouton btn:[Proceed].

Il est nécessaire de sélectionner au moins deux fichiers .arch en utilisant le bouton Bouton d’ajout ou le sous-menu permettant de sélectionner un fichier récent. Chaque fois qu’un fichier est ajouté, son nom et sa description sont rajoutés aux champs respectifs pour aider à les définir pour le fichier fusionné.

Panneau de fusion dans l’écran d’accueil
Figure 3. Panneau de fusion dans l’écran d’accueil
Il est nécessaire que les fichiers sélectionnés partagent strictement le même dictionnaire, autrement, il ne sera pas possible de réaliser la fusion.

Une fois les fichiers sélectionnés, le nom et la description remplis, il est possible de créer le fichier fusionné en cliquant sur le bouton btn:[Poursuivre].

Fenêtre principale

Fenêtre principale de l’application
Figure 4. Vue de la fenêtre principale de l’application avec données

Il s’agit de l’écran principal de l’application. En haut, on peut voir les menus et barres d’outils principales de l’application :

Menu Principal

Il s’agit du menu principal pour gérer l’application.

Barre du menu principal de l’application
Figure 5. Options de la barre du menu principal de l’application
Barre d’outils généraux

Elle contient les raccourcis (boutons) pour ouvrir et sauvegarder un fichier et aussi des boutons pour défaire/refaire des actions sur les données, pour plus d’information voir la section Menu Edit.

Barre d’outils principale de l’application
Figure 6. Boutons de la barre d’outils principale

Menu principal

Menu File

menu fichiers

Le menu menu:File[] permet d’ouvrir et de sauvegarder les fichiers de données. Une option permet aussi de choisir parmi les fichiers récents. Et l’option sortie permet de quitter l’application.

Notez surtout que l’application ne peut lire qu’un fichier à la fois. Si on ouvre un deuxième fichier, et s’il y avait des modifications pas encore sauvegardées, l’application propose de sauvegarder le travail avant de passer au nouveau fichier.

Dans le menu menu:File[Ouvrir récents], une option en bas permet d’effacer l’historique des fichiers ouverts.

Le sous-menu Exporter permet d’exporter les fichiers de données avec un filtre sur le niveau de confidentialité, par exemple, exporter les données de niveau 1 de confidentialité.

Dialogue d’export d’un fichier de données par niveau de confidentialité
Figure 7. Dialogue d’export d’un fichier de données par niveau de confidentialité

Après avoir sélectionné le fichier de sortie, il est nécessaire de sélectionner le niveau de confidentialité maximum qui sera conservé dans le fichier de sortie. La dernière option est présente pour gérer les cas particuliers où des instances enfants avec un niveau de confidentialité plus bas que le parent et devraient être exportés. Si l’anonymisation est activée, le parent sera exporté sans sa valeur, sinon le parent et ses enfants ne seront pas exportés.

Menu Edit

Menu éditer

Le menu menu:Edit[] permet de défaire/refaire toute action sur une instance d’un concept de la fenêtre principale. Les actions défaire/refaire ne peuvent pas s’appliquer aux opérations sur des fichiers telles que créer, nouveau ou sauvegarder.

La fonction défaire/refaire ne peut être utilisée que sur des modifications confirmées (avec le bouton apply) de l’instance. Ainsi, on ne peut pas défaire/refaire des modifications qui n’ont pas été confirmées dans l’éditeur d’instances.

Menu Outils

menu outils

Le menu menu:Outils[] propose plusieurs outils et raccourcis. À partir d’ici, vous pouvez accèder au menu des préférences présenté dans les préférences.

Le log d’activités affiche divers messages de l’application tels qu’erreurs et messages d’attention.

Avec ce menu, il est aussi possible d’introduire les patchs correctifs ou installer un plugin avec des nouvelles fonctions. Pour cela, cliquer sur l’élément et apparaîtra un menu pour choisir le fichier et indiquer où se trouve le patch/plugin. Après l’installation, il est conseillé de relancer l’application.

Menu Help

Menu help

Le menu menu:Help[] est pratique pour consulter directement ce Manuel de l’Utilisateur depuis l’application. Ce menu offre également la possibilité de voir l’écran 'About' dans lequel il y a des informations sur le software et les plugins/patchs installés.